[refpolicy] [PATCH] Update Python requirement in INSTALL

Christopher J. PeBenito cpebenito at tresys.com
Tue Nov 11 13:42:39 UTC 2014


On 11/10/2014 1:05 PM, Nicolas Iooss wrote:
> PyXML has not been required to build the policy and its documentation
> since at least Python 2.6, which comes with an "xml" module.
> 
> Moreover, some support scripts requires Python 2.6 or above (and are
> compatible with Python 3.4, maybe also with other versions of Python 3).
> Add the minimum supported version of Python in INSTALL.

Merged.


> ML thread: http://oss.tresys.com/pipermail/refpolicy/2014-November/007440.html
> ---
>  INSTALL | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
> 
> diff --git a/INSTALL b/INSTALL
> index f168ff591109..5250cbe73982 100644
> --- a/INSTALL
> +++ b/INSTALL
> @@ -3,7 +3,7 @@ Reference Policy has the following build requirements:
>  	* libsemanage 2.1.6
>  	* checkpolicy 2.1.8
>  	* policycoreutils 2.1.10
> -	* Python PyXML
> +	* Python >= 2.6
>  	* GCC
>  
>  To install Reference Policy sources into /etc/selinux/refpolicy/src/policy:
> 


-- 
Chris PeBenito
Tresys Technology, LLC
www.tresys.com | oss.tresys.com


More information about the refpolicy mailing list