[refpolicy] Building refpolicy fails on Arch Linux

Christopher J. PeBenito cpebenito at tresys.com
Fri Sep 2 09:16:33 CDT 2011


On 08/31/11 14:15, Nicky726 wrote:
> Dne Pá 19. srpna 2011 11.07:58 jste napsal(a): 
>> Actually its Gentoo's version.  I haven't heard any problems from Dan
>> about compile errors like this in Fedora, so I'm still thinking its your
>> toolchain.  Did you rebuild checkpolicy after changing flex and bison?
>> This pops up from time to time, the last thread I can find on it is here:
>>
>> http://marc.info/?l=selinux&m=126762983301065&w=2
>>
>> Also cc'ing Steve Smalley in case he has any additional feedback.
>>
>> Steve: maybe we should put up a page on the selinuxproject.org about
>> these flex issues.  Maybe a summary of what we know or known bad
>> versions or something.
> 
> I tried various combinations of versions of flex, bison and selinux userspace. I didn't succede on my SELinux netbook. I managed to build refpolicy on my 
> primary machine with just latest SELinux Userspace and prehistoric flex (2.5.4a-4), that is version combination which does not build the policy on my 
> netbook. I don't quite get it, especially as the software configuration is quite alike.

Unfortunately all I can suggest is to try the SELinux list for further help.  They'll be better able to sort out any toolchain issues you may have.

-- 
Chris PeBenito
Tresys Technology, LLC
www.tresys.com | oss.tresys.com


More information about the refpolicy mailing list